summaryrefslogtreecommitdiff
path: root/nodejs/shell.nix
diff options
context:
space:
mode:
authorJulien Dessaux2024-03-15 22:17:10 +0100
committerJulien Dessaux2024-03-15 22:17:10 +0100
commit01e3f05ea0d4360cb85de67928c7b5bd9ed48742 (patch)
tree1f104f229010a59800a9e7e72243e1ad3418fd50 /nodejs/shell.nix
parent[javascript] updated dependencies (diff)
downloadspacetraders-01e3f05ea0d4360cb85de67928c7b5bd9ed48742.tar.gz
spacetraders-01e3f05ea0d4360cb85de67928c7b5bd9ed48742.tar.bz2
spacetraders-01e3f05ea0d4360cb85de67928c7b5bd9ed48742.zip
[javascript] Rework the contracting loop following the asteroids changes
Diffstat (limited to 'nodejs/shell.nix')
-rw-r--r--nodejs/shell.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/nodejs/shell.nix b/nodejs/shell.nix
new file mode 100644
index 0000000..afa559e
--- /dev/null
+++ b/nodejs/shell.nix
@@ -0,0 +1,7 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+pkgs.mkShell {
+ LOCALE_ARCHIVE = "${pkgs.glibcLocales}/lib/locale/locale-archive";
+ name = "node";
+ nativeBuildInputs = with pkgs; [ ijq jq nodejs ];
+}