aboutsummaryrefslogtreecommitdiff
path: root/bastion/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bastion/CMakeLists.txt')
-rw-r--r--bastion/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/bastion/CMakeLists.txt b/bastion/CMakeLists.txt
index 0f826d2..6c87709 100644
--- a/bastion/CMakeLists.txt
+++ b/bastion/CMakeLists.txt
@@ -1,10 +1,8 @@
-include_directories("${bastion_SOURCE_DIR}/termrec/libtty/")
+include_directories("${bastion_SOURCE_DIR}/external/termrec/libtty")
include_directories("${bastion_SOURCE_DIR}/")
file(GLOB_RECURSE SOURCES *.c)
add_executable(bastion ${SOURCES})
-add_library(libtty.a STATIC IMPORTED)
-set_property(TARGET libtty.a PROPERTY IMPORTED_LOCATION "${bastion_SOURCE_DIR}/libtty.a")
-target_link_libraries(bastion libtty.a common)
+target_link_libraries(bastion libtty common)
target_link_libraries(bastion bz2 curl lzma mysqlclient pthread ssh z)