aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJulien Dessaux2019-02-14 20:51:41 +0100
committerJulien Dessaux2019-02-14 21:07:27 +0100
commita3f34674c6317930362c99f0fc40d835234843e5 (patch)
tree6c4c3afa605acf567b6b5997db4a3277738c9c68 /src/CMakeLists.txt
parentSwitched from standard makefile to cmake (diff)
downloadbastion-a3f34674c6317930362c99f0fc40d835234843e5.tar.gz
bastion-a3f34674c6317930362c99f0fc40d835234843e5.tar.bz2
bastion-a3f34674c6317930362c99f0fc40d835234843e5.zip
Moved code around
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
deleted file mode 100644
index f885850..0000000
--- a/src/CMakeLists.txt
+++ /dev/null
@@ -1,9 +0,0 @@
-include_directories("${bastion_SOURCE_DIR}/termrec/libtty/")
-
-file(GLOB_RECURSE SOURCES *.c)
-
-add_executable(bastion ${SOURCES})
-add_library(libtty.a STATIC IMPORTED)
-set_property(TARGET libtty.a PROPERTY IMPORTED_LOCATION "${bastion_SOURCE_DIR}/libtty.a")
-target_link_libraries(bastion libtty.a)
-target_link_libraries(bastion bz2 curl lzma mysqlclient pthread ssh z)