aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulien Dessaux2019-03-14 17:40:04 +0100
committerJulien Dessaux2019-03-14 17:40:04 +0100
commit3933311d47b236aec9c92b8b64f3a94d6b031a79 (patch)
treecdfa5b07dc80e86f661237b98c587d1752c2bd9f /CMakeLists.txt
parentFixed build problem with SESSION_RECORDING flag set to OFF and updated the re... (diff)
downloadbastion-3933311d47b236aec9c92b8b64f3a94d6b031a79.tar.gz
bastion-3933311d47b236aec9c92b8b64f3a94d6b031a79.tar.bz2
bastion-3933311d47b236aec9c92b8b64f3a94d6b031a79.zip
Use proper directories configuration from cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a61bd0d..c8b30ab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
-cmake_minimum_required (VERSION 3.0)
-project (bastion LANGUAGES C VERSION 0.1)
+cmake_minimum_required(VERSION 3.0)
+project(bastion LANGUAGES C VERSION 0.1.0)
set(CMAKE_VERBOSE_MAKEFILE FALSE)
set(CMAKE_BUILD_TYPE Release)
@@ -14,6 +14,9 @@ set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g -ggdb -pg -fsanitize=address")
option(LIBSSH_VERBOSE_OUTPUT "whether or not verbose output for libssh mode is activated" OFF)
option(SESSION_RECORDING "whether or not recording feature based on lib termrec is activated" ON)
+configure_file("common/config.h.in" "common/config.h")
+include_directories("${CMAKE_CURRENT_BINARY_DIR}")
+
add_subdirectory(bastion)
add_subdirectory(common)
add_subdirectory(external)