aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..d3234c1
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required (VERSION 3.0)
+project (bastion LANGUAGES C VERSION 0.1)
+
+set(CMAKE_VERBOSE_MAKEFILE FALSE)
+set(CMAKE_BUILD_TYPE DEBUG)
+
+set(CMAKE_C_FLAGS "-Wall -Werror -Wextra -pedantic")
+set(CMAKE_C_FLAGS_DEBUG "-g -ggdb -pg -fsanitize=address")
+set(CMAKE_C_FLAGS_RELEASE "-Os")
+set(CMAKE_C_FLAGS_RELWITHDEBINFO "-Os -g")
+
+option(LIBSSH_VERBOSE_OUTPOUT "whether or not verbose output for libssh mode is activated" OFF)
+
+add_subdirectory(src)