aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulien Dessaux2019-03-27 14:09:12 +0100
committerJulien Dessaux2019-03-27 15:21:16 +0100
commit3b22502cbdfd0f1c2e58d6cb0a394a817a741f49 (patch)
treeb0911a447edf96f990715160e71f94314ec0685b /CMakeLists.txt
parentAdded uthash as a git submodule (diff)
downloadbastion-3b22502cbdfd0f1c2e58d6cb0a394a817a741f49.tar.gz
bastion-3b22502cbdfd0f1c2e58d6cb0a394a817a741f49.tar.bz2
bastion-3b22502cbdfd0f1c2e58d6cb0a394a817a741f49.zip
Cleaning and reordering.
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db4fc3c..34ead63 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,16 +14,17 @@ if(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
endif()
set(CMAKE_C_FLAGS "-Wall -Werror -Wextra -pedantic")
-set(CMAKE_C_FLAGS_DEBUG "-O0 -g -ggdb -pg -fsanitize=address")
+set(CMAKE_C_FLAGS_DEBUG "-O0 -ggdb3 -pg -fsanitize=address")
set(CMAKE_C_FLAGS_RELEASE "-O2")
set(CMAKE_C_FLAGS_MinSizeRel "-Os")
-set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g -ggdb -pg -fsanitize=address")
+set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -ggdb3 -pg")
option(LIBSSH_VERBOSE_OUTPUT "whether or not verbose output for libssh mode is activated" OFF)
option(SESSION_RECORDING "whether or not recording feature based on lib termrec is activated" ON)
configure_file("common/config.h.in" "common/config.h")
include_directories("${CMAKE_CURRENT_BINARY_DIR}")
+include_directories("${CMAKE_CURRENT_SOURCE_DIR}")
add_subdirectory(bastion)
add_subdirectory(common)